您的位置:首页 > 其它

最长升序子序列

2015-08-13 11:02 288 查看
Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1: 14 1 4
Case 2: 7 1 6

思路:
用二分法(避免超时)找最小的数放在子序列里面,比如最开始的序列是 2 3 4,但是后面又发现了一个1,就把1代替之前的2,以免后面出现更长的子序列

#include<iostream>
#include<cstdio>
using namespace std;
#define  maxn 100000+10
int al[maxn], cl[maxn];
int main()
{
int n,len,left,right,mid;
while (scanf("%d",&n)!= EOF){
for (int i = 0; i < n; i++)
scanf("%d", &al[i]);
len = 0, cl[0] = -1;
for (int i = 0; i < n; i++)
{
if (al[i]>cl[len])
cl[++len] = al[i];    //把大的数放进去
else
{
left = 1, right = len;    //二分法找后面小的数放在这个子序列的前面,以免有更长的子序列

while (left <= right)
{
mid = (left + right) / 2;
if (al[i]>cl[mid])
left = mid + 1;
else
right = mid - 1;
}
cl[left] = al[i];
}
}
printf("%d\n", len);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: