您的位置:首页 > 其它

hdu 1079 Calendar Game 博弈

2015-08-13 10:35 405 查看


Calendar Game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3121 Accepted Submission(s): 1830



Problem Description

Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts
by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can
move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next
calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years
ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.



Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of
MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.



Output

Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO".



Sample Input

3 
2001 11 3 
2001 11 2 
2001 10 3




Sample Output

YES 
NO 
NO




Source

Asia 2001, Taejon (South Korea)

从终止态往后推即可

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
int month[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dp[110][13][33];
void init(){
    int yy=2001,mm=11,dd=3;
    for(int i = 1;i <= 31;i++)dp[2001-1900][12][i]=1;
    for(int i = 5;i <= 31;i++)dp[2001-1900][11][i]=1;
    int be = dp[2001-1900][11][4] = 0;
    int ans;
    int yy1,mm1,dd1,up;
    while(yy>=1900){
        ans = be;
        yy1=yy,mm1=mm+1,dd1=dd;
        if(mm1==13){
            yy1++,mm1=1;
        }
        if(mm1==2&&(yy1%400==0||(yy1%100!=0&&yy1%4==0)))up=29;
        else up = month[mm1];
        if(up>=dd1) ans = ans&dp[yy1-1900][mm1][dd1];
        be = dp[yy-1900][mm][dd] = ans^1;
        dd--;
        if(dd == 0){
            mm--;
            if(mm==0){
                yy--,mm=12;
            }
            dd = month[mm];
            if(yy%400==0||(yy%100!=0&&yy%4==0))dd=29;
        }

    }
}

int main(){
    init();
    int t;
    scanf("%d",&t);
    while(t--){
        int yy,dd,mm;
        scanf("%d%d%d",&yy,&mm,&dd);
        if(dp[yy-1900][mm][dd] == 1) printf("YES\n");
        else printf("NO\n");
    }
    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: