您的位置:首页 > 其它

HDU 1019

2015-08-12 22:27 302 查看
/*

[align=left]Problem Description[/align]
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

[align=left]Input[/align]
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

[align=left]Output[/align]
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

[align=left]Sample Input[/align]

2
3 5 7 15
6 4 10296 936 1287 792 1

 

[align=left]Sample Output[/align]

105
10296

 

[align=left]Source[/align]
East Central North America 2003, Practice

*/

//就是求几个数的最小公倍数。输出格式要注意,第一个数是样例数,第二个数是单个样例输入个数。

//

读了半天才弄懂。各种借鉴大神,最后修改类型才通过!

#include <iostream>

#include <cstdio>

using namespace std;

__int64 LCM(__int64 a,__int64 b){//求最大公倍数

    __int64 c;

    __int64 a1=a,b1=b;

    if(a<b){

        c=b;

        b=a;

        a=c;

    }

    while(b){

        c=a%b;

        a=b;

        b=c;

    }

    return (a1*b1)/a;

}

int main()

{

   int n,T;

   __int64 a[10000],result;

   scanf("%d",&T);

   while(T--){

        scanf("%d",&n);

        for(__int64 i=0;i<n;i++)

            scanf("%d",&a[i]);

        if(n==1){

            printf("%I64d\n",a[0]);

        }else{

        result=LCM(a[0],a[1]);

        for(__int64 i=2;i<n;i++)

            result=LCM(result,a[i]);

        printf("%I64d\n",result);

        }

       }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU