您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence

2015-08-12 16:31 405 查看
Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


Sample Output

6
-1


////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

分析:

KMP模板题,学KMP算法的练习题。(其实现在对KMP中的next数组理解的还不是很深,我都是一直理解为next[i]是0—i中的前缀与后缀相同的字符数)

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int A[10005];
int B[1000005];
int nxt[10005];
int n,m,t;

int makenext()
{
int l,r;
l=-1;r=0;nxt[0]=-1;
while(r<m){
if(l==-1||A[l]==A[r]){
nxt[++r]=++l;
}else{
l=nxt[l];
}
}
}

int kmp()
{
makenext();
int ln=0,lm=0;
while(ln<n&&lm<m){
if(lm==-1||B[ln]==A[lm]){
++ln;++lm;
}else{
lm=nxt[lm];
}
if(lm>=m)return ln-lm+1;
}
return -1;
}

int main()
{
//  freopen("in.txt","r",stdin);
scanf("%d",&t);
bool dec;
while(t--){
dec=true;
memset(nxt,0,sizeof(nxt));
scanf("%d%d",&n,&m);
for(int i=0;i<n;++i)scanf("%d",&B[i]);
for(int i=0;i<m;++i)scanf("%d",&A[i]);
printf("%d\n",kmp());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: