您的位置:首页 > 其它

hdu 3746 Cyclic Nacklace KMP循环节问题

2015-08-12 14:27 453 查看


Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4124 Accepted Submission(s): 1866



Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial
spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful
decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with
colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost
pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:



Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that
is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.



Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000
).



Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.



Sample Input

3
aaa
abca
abcde




Sample Output

0
2
5


循环节有关问题的证明 循环节有关问题传送门

题意:要把一个手镯凑成大于等于两个的循环,问最少需要添加几个珠子

思路:求一下最小循环节,然后看看是否是整数个循环,不是的话就差几个就补几个 最小循环节 t = len-next[len]

#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>

using namespace std;
char s[100009];
int nt[100009];

void getnext(int len)
{
    int k=-1;int j=0;
    nt[0]=-1;

    while(j<len)
    {
        if(k<0 || s[k]==s[j])
            nt[++j]=++k;
        else
            k=nt[k];
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        int len=strlen(s);
        getnext(len);

        if(nt[len]==0)
        {
            printf("%d\n",len);
            continue;
        }

//        for(int i=0;i<=len;i++)
//            cout<<next[i]<<" ";

        int t=len-nt[len];
        if(len%t==0)
        {
            puts("0");
            continue;
        }

        t=t-len%t;
        printf("%d\n",t);

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: