您的位置:首页 > 其它

HDU - 3874 Necklace (线段树 + 离线处理)

2015-08-12 11:45 381 查看
欢迎参加——每周六晚的BestCoder(有米!)

Necklace

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4003 Accepted Submission(s): 1330



Problem Description

Mery has a beautiful necklace. The necklace is made up of N magic balls. Each ball has a beautiful value. The balls with the same beautiful value look the same, so if two or more balls have the same beautiful value, we just count it once. We define the beautiful
value of some interval [x,y] as F(x,y). F(x,y) is calculated as the sum of the beautiful value from the xth ball to the yth ball and the same value is ONLY COUNTED ONCE. For example, if the necklace is 1 1 1 2 3 1, we have F(1,3)=1, F(2,4)=3, F(2,6)=6.

Now Mery thinks the necklace is too long. She plans to take some continuous part of the necklace to build a new one. She wants to know each of the beautiful value of M continuous parts of the necklace. She will give you M intervals [L,R] (1<=L<=R<=N) and you
must tell her F(L,R) of them.

Input

The first line is T(T<=10), representing the number of test cases.

For each case, the first line is a number N,1 <=N <=50000, indicating the number of the magic balls. The second line contains N non-negative integer numbers not greater 1000000, representing the beautiful value of the N balls. The third line has a number
M, 1 <=M <=200000, meaning the nunber of the queries. Each of the next M lines contains L and R, the query.

Output

For each query, output a line contains an integer number, representing the result of the query.

Sample Input

2
6
1 2 3 4 3 5
3
1 2
3 5
2 6
6
1 1 1 2 3 5
3
1 1
2 4
3 5


Sample Output

3
7
14
1
3
6对于这道题,大家可以看我博客里/article/8817327.html提供的离线处理教程后,基本能够理解离线处理的机制了,然后我们就要对照理解题目,不能出现重复的数字,所以可以离线最右边的值,将前面的值一一删除就可以得到正确答案,当然,大家还需注意的是数值取值范围为long long ,我就是在这个上面看了接近一个小时,query()函数的返回值应该也是long long ,坑爹的地方就是这里了,其他的,大家看代码基本能够秒懂的


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long LL;
#define lson rt << 1, l, mid
#define rson rt << 1|1, mid + 1, r
#define root 1, 1, N
const int MAXN = 5e4 + 5;
const int MAXM = 2e5 + 5;
const int MAXS = 1e6 + 5;
int N, M, T, pre[MAXS];
LL Ans[MAXM],Sum[MAXN << 2];

struct node {
int l, r, id;
bool operator < (const node & object) const {
return r < object.r;
}
} Node[MAXM];

void pushup(int rt) {
Sum[rt] = Sum[rt << 1] + Sum[rt << 1|1];
}

void build(int rt,int l,int r) {
if(l == r) {
scanf("%I64d", &Sum[rt]);
return;
}
int mid = (l + r) >> 1;
build(lson);
build(rson);
pushup(rt);
}

void update(int p,int rt, int l, int r) {
if(l == r) {
Sum[rt] = 0;
return;
}
int mid = (l + r) >> 1;
if(p <= mid) update(p, lson);
else update(p, rson);
pushup(rt);
}

LL query(int L, int R, int rt, int l, int r) {
if(L <= l && r <= R) {
return Sum[rt];
}
int mid = (l + r) >> 1;
LL ret = 0;
if(L <= mid) ret += query(L, R, lson);
if(R > mid) ret += query(L, R, rson);
return ret;
}

int main() {
//freopen("D://imput.txt","r",stdin);
scanf("%d", &T);
while(T --) {
scanf("%d", &N);
build(root);
scanf("%d", &M);
for(int i = 1 ; i <= M ; i ++) {
scanf("%d %d", &Node[i].l, &Node[i].r);
Node[i].id = i;
}
memset(pre, -1, sizeof(pre));
sort(Node + 1, Node + M + 1);
for(int i = 1,j = 1; i <= N; i++) {
int tmp = query(i, i, root);
if(tmp != 0 && pre[tmp] != -1) {//如果前面存在重复的数字则删除他
update(pre[tmp],root);
}
pre[tmp] = i;
while(j <= M && Node[j].r == i) {//如果右边的值等于当前的值,则进行求和,大家可以参考我博客里的教程
Ans[Node[j].id] = query(Node[j].l, Node[j].r, root);
j ++;
}
}
for(int i = 1; i <= M ; i ++) {
printf("%I64d\n", Ans[i]);
}
}
return 0;
}




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: