您的位置:首页 > 理论基础 > 数据结构算法

【暑假】[实用数据结构]UVAlive 3026 Period

2015-08-11 20:59 465 查看
UVAlive 3026 Period

题目:

Period

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description




For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) � the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output �Test case #� and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0


Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

思路:
利用KMP算法中的失配函数,如果是一个循环字串那么(i-f[i])必为一个循环节,因此只要判断(i%(i-f[i])==0) 可以整除则是循环字串。

代码:


#include<cstdio>
#define FOR(a,b,c) for(int a=(b);a<(c);a++)
using namespace std;

const int maxn = 1000000 + 10;
char s[maxn];
int f[maxn];    //大数组注意要开在函数外包括main

int main(){
int kase=0,n;
while(scanf("%d",&n)==1 && n){
scanf("%s",s);

f[0]=f[1]=0;
FOR(i,1,n){
int j=f[i];
while(j &&  s[i] != s[j]) j=f[j];
f[i+1]= s[i]==s[j]? j+1:0;
}

printf("Test case #%d\n",++kase);
FOR(i,2,n+1){  //L+1
int k=i-f[i];
if(f[i]>0 && (i%k)==0)
printf("%d %d\n",i,i/k);
}
printf("\n");
}
return 0;
}







需要注意大数组的声明位置。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: