您的位置:首页 > 产品设计 > UI/UE

POJ3061---Subsequence(尺取法)

2015-08-11 10:18 411 查看
[align=center]Subsequence[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9998 Accepted: 4052
尺取法,像尺子一样;一段一段的找;
题意:找最小区间和大于等于给定的数;

Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements
of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case,
separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

Source
Southeastern Europe 2006

#include <iostream>

#include<cstdio>

#include<cstring>

#include<algorithm>

#include<cmath>

#include<queue>

#include<stack>

#define LL long long

using namespace std;

const int maxn=100010;

#define INF 0x3f3f3f3f

LL a[maxn],sum[maxn];

int main()

{

     int t,n,m, ans,r1;

     LL cnt1;

     while(~scanf("%d",&t))

     {

         while(t--)

         {

             scanf("%d%d",&n,&m);

             a[0]=sum[0]=0;

             for(int i=1;i<=n;i++)

             {

                 scanf("%lld",&a[i]);

                 sum[i]=sum[i-1]+a[i];

             }

             a[n+1]=0;

             r1=1;cnt1=0;

             ans=INF;

             if(sum
<m)

             {

                 printf("0\n");

                 continue;

             }

             for(int i=1;i<=n;i++)

             {

                 while(r1<i||(r1<=n+1&&cnt1<m))

                 {

                     cnt1+=a[r1];

                     r1++;

                 }

                if(r1>n+1)

                    break;

                    if(cnt1>=m)

                    ans=min(ans,r1-i);

                    cnt1-=a[i];

             }

             printf("%d\n",ans);

         }

     }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: