您的位置:首页 > 其它

POJ 1942:Paths on a Grid

2015-08-11 10:17 330 查看
Paths on a Grid

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 22918Accepted: 5651
Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste
your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:



Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up?
You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input
5 4
1 1
0 0

Sample Output
126
2


给了一个n*m的格子,要从左下走到右上,问有多少种走法。

一共一定是走n+m步,这其中又必然有n步向上,m步向右。所以结果就是C[n+m]
或者C[n+m][m]

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

unsigned long long weight,height;

int main()
{
	unsigned long long small,lo;
	unsigned long long i,j,result;
	while(cin>>weight>>height)
	{
		if(weight+height==0)//被0 5这样的坑死 这样的输出1 之前我自己还先判断一下 然后输出0...
			break;
		small=min(weight,height);
		lo=weight+height;
		
		result=1;

		for(i=lo,j=1;j<=small;i--,j++)
		{
			result = (result*i)/j;
		}

		cout<<result<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: