您的位置:首页 > 其它

hdoj2888Check Corners【二维RMQ模板】

2015-08-11 08:04 218 查看
 

Check Corners

Time Limit: 2000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2204    Accepted Submission(s): 785


[align=left]Problem Description[/align]
 

Paul draw a big m*n matrix A last month, whose entries Ai,j are all integer numbers ( 1 <= i <= m, 1 <= j <= n ). Now he selects some sub-matrices, hoping to find the maximum number. Then he finds that there may be more than one maximum
number, he also wants to know the number of them. But soon he find that it is too complex, so he changes his mind, he just want to know whether there is a maximum at the four corners of the sub-matrix, he calls this “Check corners”. It’s a boring job when
selecting too many sub-matrices, so he asks you for help. (For the “Check corners” part: If the sub-matrix has only one row or column just check the two endpoints. If the sub-matrix has only one entry just output “yes”.)
 

 

[align=left]Input[/align]
 

There are multiple test cases. 

For each test case, the first line contains two integers m, n (1 <= m, n <= 300), which is the size of the row and column of the matrix, respectively. The next m lines with n integers each gives the elements of the matrix which fit in non-negative 32-bit integer. 

The next line contains a single integer Q (1 <= Q <= 1,000,000), the number of queries. The next Q lines give one query on each line, with four integers r1, c1, r2, c2 (1 <= r1 <= r2 <= m, 1 <= c1 <= c2 <= n), which are the indices of the upper-left corner
and lower-right corner of the sub-matrix in question. 

 

 

[align=left]Output[/align]
 

For each test case, print Q lines with two numbers on each line, the required maximum integer and the result of the “Check corners” using “yes” or “no”. Separate the two parts with a single space.
 

 

[align=left]Sample Input[/align]
 

4 4
4 4 10 7
2 13 9 11
5 7 8 20
13 20 8 2
4
1 1 4 4
1 1 3 3
1 3 3 4
1 1 1 1

 

 

[align=left]Sample Output[/align]
 

20 no
13 no
20 yes
4 yes

 

二维RMQ模板题

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
using namespace std;
int MAX(int a,int b)
{
return a>b?a:b;
}
int dp[301][301][9][9];
int map[301][301];
int n,m;
void init()
{
int i,j,k,u;
for(i=0;i<=(int)(log(n*1.0)/log(2.0));++i)
{
for(j=0;j<=(int)(log(m*1.0)/log(2.0));++j)
{
if(i+j)
{
for(k=1;k<=n-(1<<i)+1;++k)
{
for(u=1;u<=m-(1<<j)+1;++u)
{
if(i==0)
{
dp[k][u][i][j]=MAX(dp[k][u][i][j-1],dp[k][u+(1<<(j-1))][i][j-1]);
}
else
{
dp[k][u][i][j]=MAX(dp[k][u][i-1][j],dp[k+(1<<(i-1))][u][i-1][j]);
}
}
}
}
}
}
}
int query(int r1,int c1,int r2,int c2)
{
int k1=log((r2-r1+1)*1.0)/log(2.0);
int k2=log((c2-c1+1)*1.0)/log(2.0);
int x=MAX(dp[r1][c1][k1][k2],dp[r2-(1<<k1)+1][c2-(1<<k2)+1][k1][k2]);
int y=MAX(dp[r1][c2-(1<<k2)+1][k1][k2],dp[r2-(1<<k1)+1][c1][k1][k2]);
return MAX(x,y);
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;++i)
{
for(j=1;j<=m;++j)
{
scanf("%d",&map[i][j]);
dp[i][j][0][0]=map[i][j];
}
}
init();
int q,c1,c2,r1,r2;
scanf("%d",&q);
while(q--)
{
scanf("%d%d%d%d",&c1,&r1,&c2,&r2);
int ans=query(c1,r1,c2,r2);
printf("%d ",ans);
if(ans==map[c1][r1]||ans==map[c1][r2]||ans==map[c2][r1]||ans==map[c2][r2])
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj2888Check Corner