您的位置:首页 > 其它

POJ 3267 The Cow Lexicon(DP)

2015-08-10 09:02 288 查看
The Cow Lexicon

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 8765Accepted: 4133
Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not
make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters,
and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L

Line 2: L characters (followed by a newline, of course): the received message

Lines 3..W+2: The cows' dictionary, one word per line
Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
Sample Input
6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output
2

Source

USACO 2007 February Silver

题意:给出1个主串行n个字串,问在主串中最少删除多少字符,使得剩下的单词可以在字串中找到(可以是字串中多个字符串的结合)

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>

using namespace std;

int dp[361];
char str[361];
char a[601][361];
int n,l;

int main()
{
    while(scanf("%d%d",&n,&l)!=EOF)
    {
        scanf("%s",str);
        for(int i=0;i<n;i++)
        {
            scanf("%s",a[i]);
        }
        dp[l] = 0;
        int pl,pr;
        for(int i=l-1;i>=0;i--)
        {
            dp[i] = dp[i+1] + 1;
            for(int j=0;j<n;j++)
            {
                int len = strlen(a[j]);
                if(len<=l-i && str[i] == a[j][0])
                {
                    pl = 0;
                    pr = 0;
                    for(int k=i;k<l;k++)
                    {
                        pr++;
                        if(str[k] == a[j][pl])
                        {
                            pl++;
                            if(pl == len)
                            {
                                dp[i] = min(dp[i],dp[k+1]+pr-len);
                                break;
                            }
                        }
                    }
                }
            }
        }
        printf("%d\n",dp[0]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: