您的位置:首页 > 其它

poj2524 并查集

2015-08-09 21:56 363 查看
Ubiquitous Religions

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 27461Accepted: 13478
Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion.
The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output
Case 1: 1
Case 2: 7

Hint
Huge input, scanf is recommended.
Source
Alberta Collegiate Programming Contest 2003.10.18

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
int bin[50001];
int find(int x)
{
int r=x;
while(r!=bin[r])
r=bin[r];
int j=x,i;
while(r!=bin[j])
{
i=bin[j];
bin[j]=r;
j=i;
}
return r;
}
int Merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
bin[fx]=fy;
}
int main()
{
int n,m,num=0;
while(~scanf("%d%d",&n,&m))
{   num++;
if(n==0&&m==0)
break;
for(int i=1;i<=n;i++)
bin[i]=i;
for(int i=0;i<m;i++)
{int u,v;
scanf("%d%d",&u,&v);
Merge(u,v);
}
int count=0;
for(int i=1;i<=n;i++)
if(bin[i]==i)
count++;
cout<<"Case "<<num<<": "<<count<<endl;
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: