您的位置:首页 > 其它

BestCoder Round #50 (div.2) 1001

2015-08-08 21:19 246 查看
Problem Description

AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money
would write down his ID on that part.

Input

There are multiply cases.For each case,there is a single integer n(1<=n<=1000) in first line.In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.

Output

Output ID of the man who should be punished.If nobody should be punished,output -1.

Sample Input

3
1 1 2
4
2 1 4 3


Sample Output

1
-1


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;

int a[10010];
int ha[10110];
int main()
{
int n;
while(cin>>n)
{
memset(ha,0,sizeof(ha));
for(int i=0;i<n;i++)
{
cin>>a[i];
ha[a[i]]++;
}
int pos = -1;
for(int i=0;i<n;i++)
{
if(ha[a[i]] > n/2)
{
pos = a[i];
break;
}
}
cout<<pos<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: