您的位置:首页 > 其它

--hdu2717->搜索的范围控制

2015-08-08 15:30 316 查看
C - 开
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 2717

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

之所以把这个水题贴上,是为了警戒自己,数组超限与范围判断的时候,应该先进行范围判断,然后进行数组操作!


#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int vis[300010];

int bfs(int x,int ans){

queue<int>q;
queue<int>num;
q.push(x);
num.push(0);
while(!q.empty()){

int xx = q.front();
int nn = num.front();
num.pop();
q.pop();

if(xx == ans)return nn;
if(xx>=0&&vis[xx-1] == 0){
q.push(xx-1);
num.push(nn+1);
vis[xx-1] = 1;
}
if(xx+1<=ans&&vis[xx+1] == 0){
q.push(xx+1);
num.push(nn+1);
vis[xx+1] = 1;
}

if(2*xx <=ans*2&&vis[2*xx] == 0){
q.push(2*xx);
num.push(nn+1);
vis[2*xx] = 1;
}

}

}

int main(){

int n,m;

while(~scanf("%d%d",&n,&m)){
memset(vis,0,sizeof(vis));
vis
=1;
printf("%d\n",bfs(n,m));

}
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: