您的位置:首页 > 其它

高效算法——D 贪心,区间覆盖问题

2015-08-07 19:38 417 查看
Given several segments of line (int the X axis) with coordinates [Li , Ri ]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].

Input

The first line is the number of test cases, followed by a blank line. Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri” (|Li |, |Ri | ≤ 50000, i ≤ 100000), each on a separate line. Each test case of

input is terminated by pair ‘0 0’. Each test case will be separated by a single line.

Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1

-1 0

-5 -3

2 5

0 0

1

-1 0

0 1

0 0

Sample Output

0

1

0 1

解题思路:

1、把各区间按照x从小到大排序,如果区间1的起点大于0,则无解(因为其他区间的左起点更大);否则选择起点在s的最长区间;

2、选择区间[li, ri]后,新的起点应更新为ri,并且忽略所有区间在ri之前的部分;

程序代码:

#include <cstdio>
#include <algorithm>
using namespace std;
struct node
{
int x,y;
};
node  a[100010];
int b[100010];
int cmp( node a, node b)
{
return a.x<b.x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int m,i=0;
scanf("%d",&m);
while(scanf("%d%d",&a[i].x,&a[i].y)==2&&(a[i].x||a[i].y))
{
i++;
}
sort(a,a+i,cmp);
int k=0,x=0,y=0;
int j;
while(x<m)
{
y=x;
for( j=0;j<i;j++)
if(a[j].x<=x&&a[j].y>=y)
{y=a[j].y;b[k]=j;}
if(x==y)
{
k=0;break;
}
x=y;
k++;
}
printf("%d\n",k);
for( j=0;j<k;j++)
printf("%d %d\n",a[b[j]].x,a[b[j]].y);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: