您的位置:首页 > 其它

Power Strings POJ 2406【KMP Next的应用】

2015-08-07 16:58 288 查看
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:求子串在源字符串出现的最大次数

总结一下,如果对于next数组中的 i, 符合 i % ( i - next[i] ) == 0 && next[i] != 0 , 则说明字符串循环,而且

循环节长度为: i - next[i]

循环次数为: i / ( i - next[i] )
//算次数不需要next[i] != 0这个条件


#include<cstdio>
#include<cstring>
#define MAX 1000100
char str[MAX];
int next[MAX];
int len;
void Get_Next()
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<len)
	{
		if(j==-1 || str[i]==str[j])
		{
			++i,++j;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
int main()
{
	while(scanf("%s",str),strcmp(str,"."))
	{
		len=strlen(str);
		Get_Next();
		if((len)%((len)-next[len])==0)
			printf("%d\n",(len)/((len)-next[len]));
		else printf("1\n");
	}
	return 0;
}




#include<cstdio>
#include<cstring>
#define MAX 1000100
char str[MAX];
int next[MAX];
int len;
void Get_Next()
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<len)
	{
		if(j==-1 || str[i]==str[j])
		{
			++i,++j;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
int main()
{
	while(scanf("%s",str),strcmp(str,"."))
	{
		len=strlen(str);
		Get_Next();
		(len)%((len)-next[len])==0&&next[len]!=0?printf("%d\n",(len)/((len)-next[len])):printf("1\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: