您的位置:首页 > 其它

HDU 1003 Max Sum

2015-08-06 20:14 246 查看
题目链接 DHU 1003


Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit:
65536/32768 K (Java/Others)

Total Submission(s): 177991 Accepted Submission(s): 41516



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).



Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5




Sample Output

Case 1:
14 1 4

Case 2:
7 1 6




Author

Ignatius.L



题意:

求最大连续子段和。

分析:

我们用 sum 维护一段连续和,不断更新最大和与他的起点和终点,当 sum < 0 时再让 sum = 0,重新开始计算一段连续

和。

代码:

#include <cstdio>
#include <iostream>
using namespace std;
const int maxn = 100005;
int a[maxn];
int main()
{
    int t, n, cas = 1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        int Max = a[1], Sta = 1, End = 1, sum = 0, temp = 1;
        for(int i = 1; i <= n; i++)
        {
            sum += a[i];            //sum维护一段连续和
            if(sum > Max)
            {
                Max = sum;          //更新最大和与起点、终点
                Sta = temp;
                End = i;
            }
            if(sum < 0)         //当前的连续和小与0
            {
                sum = 0;        //重新计算
                temp = i + 1;   //从下一个元素开始
            }
        }
        printf("Case %d:\n", cas++);
        printf("%d %d %d\n", Max, Sta, End);
        if(t) printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: