您的位置:首页 > 其它

2015多校VI hdu

2015-08-06 18:58 246 查看


Cake

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 0 Accepted Submission(s): 0

Special Judge


Problem Description

There are m soda and today is their birthday. The 1-st soda has prepared n cakes with size 1,2,…,n. Now 1-st soda wants to divide the cakes into m parts so that the total size of each part is equal. 

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the m parts. Each cake must belong to exact one of m parts.




Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains two integers n and m (1≤n≤105,2≤m≤10), the number of cakes and the number of soda.
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.




Output

For each test case, output "YES" (without the quotes) if it is possible, otherwise output "NO" in the first line.

If it is possible, then output m lines denoting the m parts. The first number si of i-th line is the number of cakes in i-th part. Then si numbers follow denoting the size of cakes in i-th part. If there are multiple solutions, print any of them.




Sample Input

4
1 2
5 3
5 2
9 3




Sample Output

NO
YES
1 5
2 1 4
2 2 3
NO
YES
3 1 5 9
3 2 6 7
3 3 4 8


//#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define INF 0x3f3f3f3f
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
typedef pair<int , int> P;
#define maxn 100000 + 10

long long n, m;
int a[maxn];
int b[12][maxn];

int main()
{
    //freopen("do.txt", "r", stdin);
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%I64d%I64d", &n, &m);
        memset(a, 0, sizeof a);
        int flag = 0;
        long long t = (n * (n + 1)) / 2 ;
        if(t % m != 0 || (n < m))
        {
            printf("NO\n");
            continue;
        }

        if(t / m < n)
        {
            printf("NO\n");
            continue;
        }
        else if(t / m == n)
        {
            printf("YES\n");
            printf("1 %d\n", n);
            int cnt = 1;
            n--;
            m--;
            long long k = n / m;
            for(int j = 1; j <= k; j++)
            {
                if(j & 1)
                    for(int i = 1; i <= m; i++)
                    {
                        b[i][j] = cnt++;
                    }
                else
                    for(int i = m; i >= 1; i--)
                    {
                        b[i][j] = cnt++;
                    }
            }
            for(int i = 1; i <= m; i++)
            {
                printf("%d ", k);
                for(int j = 1; j <= k; j++)
                    j != k ? printf("%d ", b[i][j]) : printf("%d\n", b[i][j]);
            }
            continue;
        }

        if(n % m == 0)
        {
            printf("YES\n");
            int cnt = 1;
            long long k = n / m;
             for(int j = 1; j <= k; j++)
            {
                if(j & 1)
                    for(int i = 1; i <= m; i++)
                    {
                        b[i][j] = cnt++;
                    }
                else
                    for(int i = m; i >= 1; i--)
                    {
                        b[i][j] = cnt++;
                    }
            }
            for(int i = 1; i <= m; i++)
            {
                printf("%d ", k);
                for(int j = 1; j <= k; j++)
                    j != k ? printf("%d ", b[i][j]) : printf("%d\n", b[i][j]);
            }
            continue;
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: