您的位置:首页 > 其它

hdoj-2095-find your present (2)【位异或】

2015-08-06 17:21 363 查看

find your present (2)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18431 Accepted Submission(s): 7101



[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others, andyou can assume that only one number appear odd times.For example, there are 5 present,
and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

[align=left]Input[/align]
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0


[align=left]Sample Output[/align]

3
2

HintHint
use scanf to avoid Time Limit Exceeded


[align=left]Author[/align]
8600

[align=left]Source[/align]
HDU 2007-Spring Programming Contest - Warm Up (1)

[align=left]Recommend[/align]
8600 | We have carefully selected several similar problems for you:2094

1597
1593
1595
1599

本来以为这种方法一定会超时,没想到能过,可见:位运算效率还是挺高的

Exe.TimeExe.MemoryCode Len.
889MS5324K506 B
#include<stdio.h>
#include<algorithm>
using namespace  std;
int a[1000010];
int main(){
int n;
while(scanf("%d",&n),n){
int i,k;
for(i=0;i<n;++i){
scanf("%d",&a[i]);
}
sort(a,a+n);
k=0;
int ok=0;
for(i=1;i<n;++i){
if(a[i]^a[k]){
//printf("%d,%d\n",a[i],a[k]);
//printf("i-k=%d\n",i-k);
if((i-k)&1){
ok=1;
printf("%d\n",a[k]);
break;
}
else{
k=i;
}
}
}
if(!ok) printf("%d\n",a[n-1]);

}
return 0;
}


最初没想到可以直接用异或处理, 因为其他的卡片个数都是偶数,任意两个相同的数字进行异或后都是0,而异或满足交换律,运算次序无关,结果相同

Exe.TimeExe.MemoryCode Len.
748MS1404K187B
#include<stdio.h>
int main(){
int n;
while(scanf("%d",&n),n){
int a,i,res=0;
for(i=0;i<n;++i){
scanf("%d",&a);
res=res^a;
}
printf("%d\n",res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: