您的位置:首页 > 其它

Hdu 5344 MZL's xor 2015ACM多校对抗赛第五场

2015-08-06 09:41 453 查看


传送门: http://acm.hdu.edu.cn/showproblem.php?pid=5344


MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 531    Accepted Submission(s): 361


Problem Description

MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)

The xor of an array B is defined as B1 xor B2...xor Bn

 

Input

Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.

Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai−1∗m+z) mod l
1≤m,z,l≤5∗105,n=5∗105

 

Output

For every test.print the answer.

 

Sample Input

2
3 5 5 7
6 8 8 9

 

Sample Output

14
16

 

Source

2015 Multi-University Training Contest 5

 

异或规律题,当i != j 时,(Ai+Aj)与(Aj+Ai)抵消

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL long long
#define maxn 1000000
LL a[maxn];
LL n,m,z,l,T_T;
int main()
{
scanf("%lld",&T_T);
while(T_T--)
{
scanf("%lld%lld%lld%lld",&n,&m,&z,&l);
a[1] = 0;
for(int i = 2;i<=n;i++)
a[i] = (a[i-1] * m + z) % l;
LL ans = 0;
for(int i = 1;i<=n;i++)
ans = ans ^ (2*a[i]);
printf("%lld\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  2015 acm 多校 hdu 异或