您的位置:首页 > 其它

HDU 1728--【BFS && 记录转弯次数】

2015-08-06 08:52 441 查看

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19403 Accepted Submission(s): 4708



Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?


Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,

  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2
≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。



Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。


Sample Input
2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3




Sample Output
no
yes




#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define maxn 200
using namespace std;

char map[maxn][maxn];
int turn[maxn][maxn];
int n, m, k, sx, sy, ex, ey;
bool flag;
int dir[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};

struct node{
    int x, y;
};

bool check(int x, int y){
    if(x >= 0 && x < n && y >=0 && y < m && map[x][y] != '*')
        return true;
    else
        return false;
}

void bfs(int sx, int sy){
    queue<node>q;
    node st, ed;
    st.x = sx, st.y = sy;
    q.push(st);
    while(!q.empty()){
        st = q.front();
        q.pop();
        if(st.x == ex && st.y == ey){
            if(turn[st.x][st.y] - 1 <= k){
                flag = true;
                return ;
            }
        }
        for(int i = 0; i < 4; ++i){
            ed.x = st.x + dir[i][0];
            ed.y = st.y + dir[i][1];
            while(check(ed.x ,ed.y)){
                //q.push(ed);
                if(turn[ed.x][ed.y] == 0){
                    turn[ed.x][ed.y] = turn[st.x][st.y] + 1;
                    q.push(ed);
                }
                ed.x += dir[i][0];//沿着四个走到底。
                ed.y += dir[i][1];
            }
        }
    }
}

int main (){
    int T;
    scanf("%d", &T);
    while(T--){
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; ++i)
            scanf("%s", map[i]);
        scanf("%d%d%d%d%d", &k, &sy, &sx, &ey, &ex);
        sx--, sy--, ex--, ey--;
        flag = 0;
        memset(turn, 0, sizeof(turn));
        bfs(sx, sy);
        if(flag)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: