您的位置:首页 > 其它

PAT1013. Battle Over Cities (25)

2015-08-05 20:04 232 查看

1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3

Sample Output
1
0
0

此题主要考的为无向图中的连通分支的求解。以下代码采用了深度优先算法(Depth-first-search)进行求解。


#include <iostream>
#include <bitset>

using namespace std;

static int CityMap[1000][1000];
static int RemainCityMap[1000][1000];

//depth first search
void DFS(int root, bitset<1000> &IsChecked, int CityNum, int DestroyCity)
{
IsChecked.set(root);
for (int i = 1; i <= CityNum; i++)
{
if (CityMap[root][i] && !IsChecked[i] && i != DestroyCity)
DFS(i, IsChecked, CityNum, DestroyCity);
}
}

//if all is checked return 0, else return a city that is not checked
int IsAllChecked(const bitset<1000> &Ischecked, int CityNum)
{
for (int i = 1; i <= CityNum; i++)
{
if (!Ischecked.test(i))
return i;
}
return 0;
}

int main()
{
int CityNum, WayNum, CheckNum;
cin >> CityNum >> WayNum >> CheckNum;

//construct the city map
for (int i = 0; i < WayNum; i++)
{
int City1, City2;
cin >> City1 >> City2;

CityMap[City1][City2] = CityMap[City2][City1] = 1;
}
for (int i = 0; i < CheckNum; i++)
{
int DestroyCity;
cin >> DestroyCity;

bitset<1000> IsChecked;
int cnt = 0;

IsChecked.set(DestroyCity);
int CityNotChecked = IsAllChecked(IsChecked, CityNum);
while (1)
{
DFS(CityNotChecked, IsChecked, CityNum, DestroyCity);
CityNotChecked = IsAllChecked(IsChecked, CityNum);
if (!CityNotChecked)    //all checked
break;
else
cnt++;
}
cout << cnt;
if (i < CheckNum - 1)
cout << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: