您的位置:首页 > 其它

ZOJ 2100 Seeding DFS

2015-08-05 18:29 204 查看
Seeding



Time Limit: 2 Seconds
Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it
into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0



Sample Output


YES

NO

题意:

以左上角的位置为起点,n*m大的地(1<n,m<7),上下左右四个方向,判断是否能够一次性全部播种。其中'S'为石头,' . '需要播种的地。



之前做过两道这样的深搜,感觉思路其实都差不多,所以做的时候也不害怕了,ZOJ一次AC。



#include<stdio.h>
#include<string.h>
char map[10][10];
int count,flag,n,m;

void dfs(int x,int y){
	if(x<=0||y<=0||x>n||y>m||flag==1||map[x][y]=='S')
	return;
	map[x][y]='S';
	count--;
	if(count==0) {
		flag=1;
		return;
	}
	dfs(x+1,y);
	dfs(x-1,y);
	dfs(x,y+1);
	dfs(x,y-1);
	map[x][y]='.';
	count++;
}

int main(){
	while(~scanf("%d%d",&n,&m),n|m){
		count=n*m;
		flag=0;
		int i,j;
		for(i=1;i<=n;i++){
			getchar();
			for(j=1;j<=m;j++){
				scanf("%c",&map[i][j]);
				if(map[i][j]=='S'){
					count--;
				}
			}
		}
		dfs(1,1);
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
} 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: