您的位置:首页 > 其它

zoj 2100Seeding(dfs+回溯)

2015-08-05 09:20 393 查看
ZOJ Problem Set - 2100

Seeding

Time Limit: 2 Seconds
Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.
Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it
into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0



Sample Output


YES

NO

Tom想给农田播种,为了不伤害机器 ,他不能走有石头的‘S’,但是又不能走已经播过的地,问他能不能把所有的地都播完。

#include<stdio.h>
#include<string.h>
char a[20][20];
int n,m,sum,flag;
int dir[4][2]={0,1,0,-1,1,0,-1,0};//定义一个二维数组表示上下左右 
bool junde(int x,int y)//判断是不是超出界限或是遇见石头 
 {
 	if(x<0||x>=n||y>=m||y<0)
 	return 0;
 	if(a[x][y]=='S')
 	return 0;
 	return 1;
 }
 void dfs(int x,int y)
 {
 	if(sum==0)//如果sum==0表示已经成功走完最后一点 
 	{
 		flag=1;
 		return ;
 	}
 	for(int i=0;i<4;++i)
 	{
 	int	dx=x+dir[i][0];//上下左右横坐标 
 	int	dy=y+dir[i][1];//上下左右纵坐标 
 	if(junde(dx,dy))//能进入if语句说明都是没有超出界限的"." 
 	{
 		a[dx][dy]='S';//标记成 S 
 		sum--;//代表已播过 
 		dfs(dx,dy);//进入这个点的上下左右,如果遇见石头或超出范围那么回溯到上一次dfs要把上一次的'S'点变成"."以此类推重新找路(回溯) 
 		sum++;
 		a[dx][dy]='.';
 	}
 	}
 }

int main()
{
	int i,j;
	while(scanf("%d %d",&n,&m),n||m)//输入0 0 不显示结果 
	{
		sum=m*n;//最大播的种子数 
		flag=0;
		for(i=0;i<n;i++)
	{
		scanf("%s",a[i]);//每行输入字符串表示土地情况 
		for(j=0;j<m;j++)
		{
			if(a[i][j]=='S')//如果遇见石头把最大种子减去石头数剩下的都是可以播种的 
				sum--;
		}
		}
		a[0][0]='S';//从0 0 开始dfs 把已经播过种的地方标记一下就是变成石头以后就不能播这个点了 
		sum--;//标记一下 表示已经播过种了 
		dfs(0,0);
		if(flag)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: