您的位置:首页 > 产品设计 > UI/UE

UVA1152 4Values whose Sum is 0

2015-08-04 21:54 323 查看
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) $ \in$AxBxCxD are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
1

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题解:不超时最好。。先枚举a,b,然后检查-(c+d)的值,还是二分优化。

AC代码:

#include <algorithm>
#include <iostream>
using namespace std;
const int Max = 4000 + 10;
int a[Max],b[Max],c[Max],d[Max];
int ab[17000000];
int total;
int main()
{
int t;
cin>>t;
while(t--)
{
int n;
cin>>n;
for(int i=0; i<n; i++)
{
cin>>a[i]>>b[i]>>c[i]>>d[i];
}
int k=0;
for(int i=0;i<n; i++)
{
for(int j=0;j<n; j++)
{
ab[k]=a[i]+b[j];
k++;
}
}
sort(ab,ab+k);
total=0;
int s,l,r,mid;
for(int i=0; i<n; i++)
{
for(int j=0; j<n; j++)
{
int x=-c[i]-d[j];
l=0,r=k-1;
while(l<=r)
{
mid=(l+r)/2;
if(ab[mid]>x)
r=mid-1;
else if(ab[mid]<x)
l=mid+1;
else
{
for(s=mid;s>=0;s--)
{
if(ab[s]==x)
total++;
else
break;
}
for(s=mid+1; s<k; s++)
{
if(ab[s]==x)
total++;
else
break;
}
break;
}
}
}
}
cout<<total<<endl;
if(t>0)
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: