您的位置:首页 > 其它

Prime Ring Problem

2015-08-03 21:24 399 查看

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 15   Accepted Submission(s) : 6
[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

[align=left]Input[/align]
n (0 < n < 20).
 

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order. You are to write a program that completes above process. Print a blank line after each case.

 

[align=left]Sample Input[/align]

6
8

 

[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
C语言程序代码/*程序本身比较简单,易懂,但要将求素数、全排、回溯联系起来,这就有点难想了。*/#include<stdio.h>
#include<math.h>
#include<string.h>
int n,a[22],v[22];
int f(int x)
{
 for(int i=2;i<=sqrt(x);i++)
  if(x%i==0)
   return 0;
   return 1;
}
void dfs(int s)
{
 int i,j;
 if(s==n+1&&f(a
+a[1]))//最后一个数和第一个数的判断
 {
  for(i=1;i<=n-1;i++)
  {
   printf("%d ",a[i]);
  }
  printf("%d\n",a
);
  return;
 }
 for(j=2;j<=n;j++)
 {
  if(f(j+a[s-1])&&v[j]==0)
  {
   v[j]=1;//回溯 
   a[s]=j;
   dfs(s+1);
   v[j]=0;
  }
 }
}
int main(){
 int i,m=1;
 while(scanf("%d",&n)!=EOF)
 {
  memset(v,0,sizeof(v));
  a[1]=1;
  printf("Case %d:\n",m++);
  dfs(2);
  printf("\n");
 }
 return 0;
}/*补充::
主要讲一下全排,看代码就能懂,可以当回溯模板来用
*/
#include<stdio.h>
#include<string.h>
int n,m,a[22],b[22],c[22];
void dfs(int v)
{
 if(v>=n)
 {
  for(int i=0;i<n;i++)
   printf("%d ",a[i]);
   printf("\n");
   return ;
 }
 for(int i=1;i<=n;i++)
 {
  if(!c[i])
  {
   c[i]=1;
   a[v]=i;
   dfs(v+1);
   c[i]=0;
  }
 }
}
int main(){
 while(scanf("%d",&n)!=EOF)
 {
  memset(c,0,sizeof(c));
  dfs(0);
 }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: