您的位置:首页 > 其它

POJ 1129 Channel Allocation(染色)

2015-08-03 20:40 369 查看
Channel Allocation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 13191Accepted: 6746
Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere
with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.
Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example,
ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when
only one channel is required.
Sample Input
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output
1 channel needed.
3 channels needed.
4 channels needed.

相邻的点需要是不同的颜色,问需要最少多少种颜色,如A:BC,与A相连的点有B,C, 最少需要两种颜色,A一种,B,C一种。。。

对于给定的A:BC ,我们可以先判断B,C是否已经染色, 若有颜色,则A 取一种与他们不同的一种颜色 (颜色为1~n,小的先取),否则A直接取最小的颜色,最后对每个点统计颜色种数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <stdlib.h>
#include <algorithm>
#include <cmath>
#include <map>
#define inf 0x3f3f3f3f
#define N 30
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        char s[110];
        int b
;
        int c
;

        memset(c,0,sizeof(c));
       for(int i=0;i<n;i++)
       {
           scanf("%s",s);
            memset(b,0,sizeof(b));
           int len=strlen(s);
           for(int j=2;j<len;j++)
           {
               if(c[s[j]-'A'])
               {
                   b[c[s[j]-'A']]=1;
               }
           }
           for(int j=1;j<=n;j++)
           {
               if(!b[j])
               {
                   c[i]=j;
                   break;
               }
           }
       }
       memset(b,0,sizeof(b));
       int ans=0;
       for(int i=0;i<n;i++)
       {
           if(!b[c[i]])
           {
               ans++;
               b[c[i]]=1;
           }
       }
        if(ans==1)
            printf("%d channel needed.\n",ans);
        else
            printf("%d channels needed.\n",ans);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: