您的位置:首页 > 其它

HDU 1312 Red and Black【递归】

2015-08-03 19:35 495 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13111 Accepted Submission(s): 8127



[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't
move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are
not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


[align=left]Sample Output[/align]

45
59
6
13


[align=left]Source[/align]
Asia 2004, Ehime (Japan), Japan
Domestic

题意:

实际就是让求@上下左右方向上的小黑点(。)的个数!

思路:

我们可以用到递归的方法来计算,每次都去找@现在的位置的前后左右方向上的小黑点,如果有则count++,最终得到的结果,就是我们的所求!

代码:

/*
因为需要每次都得找当前位置周围的小黑点,所以我们要将
大问题化成小问题,我们只求目前的@位置的上下左右小黑点的个数
,这个比较容易,然后每次都是这样,用到的方法都相同,并且有终止条件,
所以我们比较容易想到递归,这个题就用到了递归的方法!!!!!
*/
#include <stdio.h>
char a[22][22];

int n,m,count;
void f(int x,int y)//找@所处的位置的小黑点的个数,并进行递归统计
{
if(x<1||x>m||y<1||y>n)	return;
if(a[x][y]=='#')	return;
count++;
a[x][y]='#';
f(x-1,y);//左
f(x+1,y);//右
f(x,y-1);//下
f(x,y+1);//上
}

int main()
{
int i,j,k,x,y;
while(scanf("%d%d",&n,&m)&&(n||m))
{
count=0;
for(i=1;i<=m;i++)//输入字符
{
getchar();//吸收回车
for(j=1;j<=n;j++)
{
scanf("%c",&a[i][j]);
if(a[i][j]=='@')//找@
x=i,y=j;
}
}
f(x,y);//计数小黑点
printf("%d\n",count);//输出小黑点的总数
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: