您的位置:首页 > 其它

hdu 5327

2015-08-03 18:07 239 查看
Olympiad

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 564 Accepted Submission(s): 406

Problem Description

You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful).
Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (a≤b). Please be fast to get the gold medal!

Input

The first line of the input is a single integer T (T≤1000), indicating the number of testcases.

For each test case, there are two numbers a and b, as described in the statement. It is guaranteed that 1≤a≤b≤100000.

Output

For each testcase, print one line indicating the answer.

Sample Input

2

1 10

1 1000

Sample Output

10

738

//题意:给你两个区间求区间内的美丽整数的数量 定义为:整数的每一位数不同

//区间 1 100000 所以打表查询

#include <stdio.h>
#include <string.h>

int a[100005];
int b[10];
int main()
{
memset(a,0,sizeof(a));
for(int i=1;i<=100000;i++)
{
int k=i;
memset(b,0,sizeof(b));
while(k)
{

b[k%10]++;  //将每个数用作数组的下标 如果值大于2 说明重复了
k=k/10;
}
int flag=0;
for(int k=0;k<10;k++)
{
if(b[k]>=2)
{
flag=1;;
break;
}
}
if(!flag)
a[i]=a[i-1]+1;
else
a[i]=a[i-1];
}
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
printf("%d\n",a[m]-a[n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: