您的位置:首页 > 其它

Radar Installation(贪心,可以转化为今年暑假不ac类型)

2015-07-31 20:32 435 查看

Radar Installation

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 54 Accepted Submission(s) : 28
[align=left]Problem Description[/align]
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

[align=left]Input[/align]
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

[align=left]Output[/align]
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

[align=left]Sample Input[/align]

3 2 1 2 -3 1 2 1 1 2 0 2 0 0

[align=left]Sample Output[/align]

Case 1: 2 Case 2: 1
题解:先转化为区间点,再排序,区间找点;
代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct Node{
double s,e;
};
int n,d,k;
Node area[1010];
int cmp(Node a,Node b){
return a.e<b.e;
}
int change(int x,int y){
if(y>d)return 0;
double a,b,m=sqrt(d*d-y*y);
a=x-m;b=x+m;
area[k].s=a;area[k].e=b;k++;
return 1;
}
int main(){int t,x,y,flot,temp,num,l=0;
while(scanf("%d%d",&n,&d),n||d){k=0;flot=1;temp=0;num=1;l++;
for(int i=0;i<n;i++){
scanf("%d%d",&x,&y);
t=change(x,y);
if(!t)flot=0;
}
sort(area,area+k,cmp);
for(int i=0;i<k;i++){
if(area[i].s>area[temp].e)temp=i,num++;
}
printf("Case %d: %d\n",l,num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: