您的位置:首页 > 其它

POJ 1961 Period(KMP next数组巧用)

2015-07-31 16:49 585 查看
Description





For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 ≤ i ≤ N)
we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 ≤ N ≤ 1 000 000) � the size of the string S. The second line contains the string S. The input
file ends with a line, having the number zero on it.

Output

For each test case, output �Test case #� and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K
separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0


Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4


题意:在给出的字符串中,求出现次数超过两次的前缀出现的末位置和次数。(一定要是最短的前缀,比如第二个样例的aabaab就没有作为一个出现两次的前缀输出,aab才是最短的)

用KMP算法中的next数组可解。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1000005];
int n,f[1000005];
int main()
{
int t=1;
while(scanf("%d",&n),n)
{
scanf("%s",s);
f[0]=f[1]=0;
for(int i=1;i<n;i++)
{
int j=f[i];
while(j&&s[i]!=s[j])
j=f[j];
f[i+1]=(s[i]==s[j]?j+1:0);
}
printf("Test case #%d\n",t++);
for(int i=1;i<n;i++)
{
if(i-f[i]!=0&&f[i+1]&&f[i+1]%(i-f[i])==0)
printf("%d %d\n",i+1,(i+1)/(i-f[i]));
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: