您的位置:首页 > 其它

POJ 3349 Snowflake Snow Snowflakes

2015-07-31 14:48 281 查看
Language:
Default

Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 34684 Accepted: 9105
Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake
has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six
integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms.
For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output
Twin snowflakes found.

判断 给出的 几个由6个数字组成的序列 是否存在 相同的雪花 
(即从某一点开始顺时针或逆时针读取)

hash 解法 ,但是每次要决定好怎么使用这个HASH  这次选择存入雪花的6个数值的和

#include <iostream>
#include <vector>
#include <cstdio>
#include <cstring>

using namespace std;
#define maxn 10949 //hash的大小最好是素数
vector<int> hash[maxn];
int arm[100005][6];
bool comp(int a,int b) //判断雪花是否相同
{
int i,j,k;
for( i=0;i<6;i++){
if( arm[a][0]==arm[b][i]){
for( j=(i-1+6)%6, k=1 ; k<6 && arm[a][k]==arm[b][j]; j=((--j)+6)%6, k++);//逆时针比较
if( k==6 ) return true;
for( j=(i+1)%6 ,k=1; k<6 && arm[a][k]==arm[b][j]; j=(++j)%6 ,k++) ; //顺时针
if( k==6) return true;
}
}
return false;
}
int main()
{
int n,i,sum,j,len,r;
while( scanf("%d",&n)!=EOF){

memset(arm,0,sizeof(arm));
for( i=0;i<maxn;i++) hash[i].clear();
bool flag=false;

for( i=0;i<n&&!flag;i++){
sum=0;
for( j=0;j<6;j++){
scanf("%d",&arm[i][j]);
sum+=arm[i][j];
}
r=sum%maxn;
len=hash[r].size();
for( j=0;j<len;j++){ //在 和 相同的前提下比较有没有
a52a
相同的雪花
if( comp( i, hash[r][j] ) ){
flag=true;
break;
}
}
if(!flag) hash[r].push_back(i);
}
if( flag){
for( ;i<n;i++){ //边输入边判断可能还有没有输完的
for(j=0;j<6;j++)
scanf("%*d");
}
printf("Twin snowflakes found.\n");
}
else
printf("No two snowflakes are alike.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: