您的位置:首页 > 其它

杭电 HDU ACM 1175 连连看(麻烦的bfs)

2015-07-31 10:14 134 查看
连连看

Time Limit:10000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u

SubmitStatusPracticeHDU
1175

Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。

玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。



Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。

注意:询问之间无先后关系,都是针对当前状态的!



Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。



Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0


Sample Output

YES
NO
NO
NO
NO
YES 

这个题目当时坑了我一个下午时间……。代码漏洞百出,并且老是出现意想不到的字母打错,并且最坑的一点就是,dir数组 元素排列不一样就错 ,鬼知道为啥。
和我之前做的一个题目很是类似。只需bfs一搜到底,按照层数作为bfs深度,并且队列中只需加入可能能够满足条件的点。在按照层数扩展的过程中,寻找终点

同时加上最开始的些许剪枝。足够优化。
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=1003;
int cnt[INF][INF];
int vis[INF][INF];
int dir[4][2] = {{-1,0}, {0, 1}, {1, 0}, {0, -1}};
int n,m;
int sx,sy,ex,ey;
struct Node
{
    int x,y,step;
    Node(int x,int y,int step):x(x),y(y),step(step) {}
    Node() {}
};

void bfs(int x,int y)
{
    queue<Node>q;
    Node next;
    vis[x][y]=1;
    q.push(Node(x,y,0));
    while(!q.empty())
    {
        Node u=q.front();//cout<<"u.x="<<u.x<<"u.y="<<u.y<<"u.step="<<u.step<<endl;
        q.pop();
        for(int i=0; i<4; i++)
        {
            next.x=u.x+dir[i][0];
            next.y=u.y+dir[i][1];
            next.step=u.step;

            while(!vis[next.x][next.y]&&next.step<3&& cnt[next.x][next.y]==0&& next.x>=1&&next.x<=n&&next.y>=1&&next.y<=m)
            {
                vis[next.x][next.y]=1;
                next.step+=1;
                q.push(next);
                next.step-=1;
                next.x+=dir[i][0];
                next.y+=dir[i][1];

            }
            if(next.x==ex&&next.y==ey&&next.step<3)
            {
                printf("YES\n");
                return ;
            }
        }
    }
    printf("NO\n");
    return ;
}

int main()
{
    while(cin>>n>>m,n+m)
    {

        memset(cnt,0,sizeof(cnt));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                scanf("%d",&cnt[i][j]);

        int qu;
        scanf("%d",&qu);
        for(int i=0; i<qu; i++)
        {
            memset(vis,0,sizeof(vis));
            scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
            if(cnt[sx][sy]==0||cnt[ex][ey]==0)
                printf("NO\n");
            else if(sx==ex&&sy==ey)
                printf("NO\n");
            else if(cnt[sx][sy]!=cnt[ex][ey])
                printf("NO\n");
            else
                bfs(sx,sy);
        }
    }
    return 0;
}
/*
3 4
1 2 3 4
0 3 0 0
0 0 3 1
4
1 1 3 4
*/


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: