您的位置:首页 > 其它

The number of divisors(约数) about Humble Numbers

2015-07-31 10:08 274 查看

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3033 Accepted Submission(s):
1465


[align=left]Problem Description[/align]
A number whose only prime factors are 2,3,5 or 7 is
called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15,
16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now
given a humble number, please write a program to calculate the number of
divisors about this humble number.For examle, 4 is a humble,and it have 3
divisors(1,2,4);12 have 6 divisors.

[align=left]Input[/align]
The input consists of multiple test cases. Each test
case consists of one humble number n,and n is in the range of 64-bits signed
integer. Input is terminated by a value of zero for n.

[align=left]Output[/align]
For each test case, output its divisor number, one line
per case.

[align=left]Sample Input[/align]

4

12

0

[align=left]Sample Output[/align]

3

6

#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
long long n;
while(cin>>n&&n)
{
long long a[4]={1,1,1,1};
int b[4]={2,3,5,7},i;
for(i=0;i<4;i++)
{
while(n%b[i]==0)
{
a[i]++;
n=n/b[i];
}
}
cout<<a[0]*a[1]*a[2]*a[3]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: