您的位置:首页 > 其它

Can you solve this equation?

2015-07-30 23:20 253 查看


Can you solve this equation?


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)


Total Submission(s) : 113   Accepted Submission(s) : 69


Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

Sample Input

2
100
-4

 

Sample Output

1.6152
No solution!C语言程序代码/*
简单的二分法题, 
*/
#include<stdio.h>
#include<math.h>
double f(double x)
{
return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main(){
int n,t,i;
double l,r,mid,y;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
if(y<f(0)||y>f(100))
printf("No solution!\n");
else
{
l=0;r=100;mid=0;
while(r-l>1e-10)
{
mid=(l+r)/2;
if(f(mid)-y>1e-10)
r=mid;
else
l=mid;
}
printf("%.4lf\n",r);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: