您的位置:首页 > 其它

HDU-5327 Olympiad

2015-07-30 20:26 369 查看
http://acm.hdu.edu.cn/showproblem.php?pid=5327

Olympiad

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 182 Accepted Submission(s): 130

[align=left]Problem Description[/align]
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (a≤b)


. Please be fast to get the gold medal!

[align=left]Input[/align]
The first line of the input is a single integer T (T≤1000)


, indicating the number of testcases.
For each test case, there are two numbers a


and b


, as described in the statement. It is guaranteed that 1≤a≤b≤100000


.

[align=left]Output[/align]
For each testcase, print one line indicating the answer.

[align=left]Sample Input[/align]

2

1 10
1 1000

[align=left]Sample Output[/align]

10

738

#include<iostream>
#include<cstdio>
using namespace std;
int a[100000];
int g(int n)
{
int a[10],r=0,q,i,flag=0;;
while(n)
{
q=n%10;
a[r++]=q;
for(i=0;i<r-1;i++)
{
if(q==a[i])
flag=1;
}
n=n/10;
if(flag==1)
break;
}
if(flag==0)
return 0;
else
return 1;

}
void fun()
{
int i;
a[0]=0;
for(i=1;i<=100000;i++)
{
if(g(i)==0)
a[i]=a[i-1]+1;
else
a[i]=a[i-1];

}
}
int main()
{
fun();
int t,n,m;
scanf("%d",&t);
while(t--)
{

scanf("%d%d",&n,&m);
if(a
>a[n-1])
printf("%d\n",a[m]-a
+1);
else
printf("%d\n",a[m]-a
);

}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: