您的位置:首页 > 产品设计 > UI/UE

HDOJ 题目4027 Can you answer these queries?(线段树,区间减为平方根,区间求和)

2015-07-30 16:09 483 查看


Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 10057 Accepted Submission(s): 2305



Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease
the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for
help.

You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF.

For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)

The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.

The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)

For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query
of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8


Sample Output

Case #1:
19
7
6


Source

The 36th ACM/ICPC Asia Regional
Shanghai Site —— Online Contest

Recommend

lcy | We have carefully selected several similar problems for you: 3308 2871 1542 3397 4028

用int是超时,用__int64 过了

ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
__int64 node[400100];
void build_tr(int l,int r,int tr)
{
if(l==r)
{
scanf("%I64d",&node);
return;
}
//node.sum=0;
int m=(l+r)>>1;
build_tr(l,m,tr<<1);
build_tr(m+1,r,tr<<1|1);
node=node[tr<<1]+node[tr<<1|1];
}
void update(int L,int R,int l,int r,int tr)
{
if(node==r-l+1)
return;
if(l==r)
{
node=sqrt((double)node);
return;
}
int m=(l+r)>>1;
if(L<=m)
{
update(L,R,l,m,tr<<1);
}
if(m<R)
{
update(L,R,m+1,r,tr<<1|1);
}
node=node[tr<<1]+node[tr<<1|1];
}
__int64 query(int L,int R,int l,int r,int tr)
{
if(L<=l&&r<=R)
{
return node;
}
int m=(l+r)>>1;
__int64 ans=0;
if(L<=m)
ans+=query(L,R,l,m,tr<<1);
if(m<R)
ans+=query(L,R,m+1,r,tr<<1|1);
return ans;
}
int main()
{
int n,c=0;;
while(scanf("%d",&n)!=EOF)
{
printf("Case #%d:\n",++c);
build_tr(1,n,1);
int q;
scanf("%d",&q);
while(q--)
{
int c,a,b;
scanf("%d%d%d",&c,&a,&b);
if(a>b)
{
a^=b;
b^=a;
a^=b;
}
if(!c)
{
update(a,b,1,n,1);
}
else
{
printf("%I64d\n",query(a,b,1,n,1));
}
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: