您的位置:首页 > 其它

杭电1865 more is better

2015-07-29 19:58 253 查看

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 18668    Accepted Submission(s): 6862


[align=left]Problem Description[/align]
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

[align=left]Input[/align]
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)
 

[align=left]Output[/align]
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

 

[align=left]Sample Input[/align]

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

 

[align=left]Sample Output[/align]

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
就是给你一系列数据,这些数据如果能结合到一块就会结合成一棵树,并查集思想。问题就是求出得到的所有树中最大的一棵树有多少节点。注意要求的节点数比较多 ,不用巧妙的方法容易超内存,但是用递归会爆栈。话不多说见代码。
#include<stdio.h>
#define max 10000100
int set[max],per[max],sum=0;
int find(int p)
{
int t;
int child=p;
while(p!=set[p])
{
p=set[p];
}
while(child!=p)
{
t=set[child];//压缩路径
set[child]=p;//让树上的子节点直接与 根节点相连
child=t;//进行下一个节点
}
return p;
}
void join(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
set[fx]=fy;//连接两个节点
per[fy]+=per[fx];//让两棵树丄节点相加
if(sum<per[fy])
{
sum=per[fy];
}
}
}
int main()
{
int country,i,a,b;
while(scanf("%d",&country)!=EOF)
{
if(country==1)
{
printf("1\n");
continue;
}
for(i=0;i<=max;i++)
{
set[i]=i;
per[i]=1;
}
for(i=1;i<=country;i++)
{
scanf("%d%d",&a,&b);
join(a,b);//
}
printf("%d\n",sum);
sum=0;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: