您的位置:首页 > 其它

POJ 1276 Cash Machine 最多机器

2015-07-29 10:41 281 查看
原题: http://poj.org/problem?id=1276

题目:

Cash Machine

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 29785 Accepted: 10710

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350

633 4 500 30 6 100 1 5 0 1

735 0

0 3 10 100 10 50 10 10

Sample Output

735

630

0

0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

思路:

输入最大背包容量,物品种类数,再依次输入物品数目和重量,求出最多能装多少容量的物品。

显然是一个需要用二进制优化的多重背包问题。

代码:

#include <iostream>
#include"string.h"
#include"stdlib.h"
#include"cstdio"

int num[15];
int value[15];
int dp[120005];
using namespace std;

int m;
int tt;
void init()
{
memset(dp,0,sizeof(dp));
memset(value,0,sizeof(value));
memset(num,0,sizeof(num));
}
void backpack()
{
for(int i=1; i<=tt; i++)
{
//相对有限的容量,有限的个数用不完,
//可在满足容量条件下自由取,等价于无数个,转化成完全背包。
if(num[i]*value[i]>=m)
{
for(int j=value[i]; j<=m; j++)
{
dp[j]=max(dp[j],dp[j-value[i]]+value[i]);
}
}
else    //将当前物品按二进制进行分块,看作01背包处理。
{
int rem=num[i];
int nu=1;
int val=value[i]*nu;
while(nu<rem)
{
for(int j=m; j>=nu*value[i]; j--)
{
dp[j]=max(dp[j],dp[j-val]+val);
}
rem=rem-nu;
nu=nu*2;
val=val*2;
}
nu=rem;
val=value[i]*nu;
for(int j=m; j>=nu*value[i]; j--)
{
dp[j]=max(dp[j],dp[j-val]+val);
}
}
}
}

int main()
{

while(scanf("%d",&m)!=EOF)
{
init();

scanf("%d",&tt);
for(int i=1;i<=tt;i++)
{
scanf("%d %d",&num[i],&value[i]);
}
backpack();
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: