您的位置:首页 > 其它

【hdu】【Robberies】

2015-07-29 10:19 246 查看


Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16086 Accepted Submission(s): 5890



Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.



Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .



Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.



Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05




Sample Output

2
4
6




Source

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;

int T;
double P;
int N;
const int maxn = 110;
double v[maxn];
int w[maxn];
double dp[10005];
int main()
{
	freopen("1.txt","r",stdin);
	scanf("%d",&T);
	while(T --)
	{
		scanf("%lf%d",&P,&N);
		int sum = 0;
		P = 1 - P;
		for(int i=0;i<N;i++)
		{
			scanf("%d%lf",&w[i],&v[i]);
			v[i] = 1 - v[i];
			sum += w[i];
		}
		memset(dp,0,sizeof(dp));
		dp[0] = 1.0;	
		for(int i=0;i<N;i++)
		{
			for(int j=sum;j>=w[i];j--)

			{
				dp[j] = max(dp[j],dp[j-w[i]] * v[i]);
			}
		}
		for(int i=sum;i>=0;i--)
		{
			if(dp[i] > P)
			{
				printf("%d\n",i);
				break;
			}
		}
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: