您的位置:首页 > 产品设计 > UI/UE

UVA133-The Dole Queue

2015-07-28 22:58 309 查看
Description




In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen
as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting
m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until
no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the
end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive
pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output

4 8, 9 5, 3 1, 2 6, 10, 7

where

represents a space.

注意这n个人是个循环,要注意循环越界时的表示。

代码如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int f[25];
int p1,p2;
int n,k,m;
int go(int p,int d,int t)
{
while(t--)
{
do
{
p=(p+d+n-1)%n+1;
}while(f[p]==0);
}
return p;
}
int main()
{
int c;
while(scanf("%d%d%d",&n,&k,&m)!=-1&&n&&k&&m)
{
memset(f,1,sizeof(f));
c=n;
p1=n;p2=1;
while(c)
{
p1=go(p1,1,k);
p2=go(p2,-1,m);
printf("%3d",p1);c--;
if(p2!=p1)
{
printf("%3d",p2);c--;
}
f[p1]=f[p2]=0;
if(c)
printf(",");
}
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: