您的位置:首页 > 其它

HDOJ 5302 Connect the Graph 构造

2015-07-28 09:59 399 查看
如果1度的点不是偶数,则无解

构造一个环,这样所有的点都可以有俩个度.其他所有情况都可以通过删掉一些边来得到,而且黑边和白边是互相独立的....考虑到不能有重边,则至少得有2*n条边,所以n==4的情况(1 2 1)需要特判


Connect the Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 334    Accepted Submission(s): 110
Special Judge


Problem Description

Once there was a special graph. This graph had n vertices
and some edges. Each edge was either white or black. There was no edge connecting one vertex and the vertex itself. There was no two edges connecting the same pair of vertices. It is special because the each vertex is connected to at most two black edges and
at most two white edges. 

One day, the demon broke this graph by copying all the vertices and in one copy of the graph, the demon only keeps all the black edges, and in the other copy of the graph, the demon keeps all the white edges. Now people only knows there are w0 vertices
which are connected with no white edges, w1 vertices
which are connected with 1 white
edges, w2 vertices
which are connected with 2 white
edges, b0 vertices
which are connected with no black edges, b1 vertices
which are connected with 1 black
edges and b2 vertices
which are connected with 2 black
edges.

The precious graph should be fixed to guide people, so some people started to fix it. If multiple initial states satisfy the restriction described above, print any of them.

 

Input

The first line of the input is a single integer T (T≤700),
indicating the number of testcases. 

Each of the following T lines
contains w0,w1,w2,b0,b1,b2.
It is guaranteed that 1≤w0,w1,w2,b0,b1,b2≤2000 and b0+b1+b2=w0+w1+w2.

It is also guaranteed that the sum of all the numbers in the input file is less than 300000.

 

Output

For each testcase, if there is no available solution, print −1.
Otherwise, print m in
the first line, indicating the total number of edges. Each of the next m lines
contains three integers x,y,t,
which means there is an edge colored t connecting
vertices x and y. t=0 means
this edge white, and t=1 means
this edge is black. Please be aware that this graph has no self-loop and no multiple edges. Please make sure that 1≤x,y≤b0+b1+b2.

 

Sample Input

2
1 1 1 1 1 1
1 2 2 1 2 2

 

Sample Output

-1
6
1 5 0
4 5 0
2 4 0
1 4 1
1 3 1
2 3 1

 

Source

2015 Multi-University Training Contest 2

 

/* ***********************************************
Author :CKboss
Created Time :2015年07月27日 星期一 21时58分28秒
File Name :HDOJ5302.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=6100;

int n,w0,w1,w2,b0,b1,b2;
int black[maxn],white[maxn];

struct Edge
{
int u,v,c;
void toString()
{
printf("%d <----> %d : %d\n",u,v,c);
}
};

void init()
{
for(int i=1;i<=n;i++) black[i]=i;
int nx=1;
for(int i=1;i<=n;i+=2,nx++) white[nx]=i;
for(int i=2;i<=n;i+=2,nx++) white[nx]=i;
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);

int T_T;
scanf("%d",&T_T);
while(T_T--)
{
scanf("%d%d%d%d%d%d",&w0,&w1,&w2,&b0,&b1,&b2);
n=b0+b1+b2;
init();

if(b1%2||w1%2)
{
puts("-1"); continue;
}
if(n<=4)
{
/// else
puts("4\n1 2 0\n1 3 0\n2 3 1\n3 4 1");
continue;
}
else
{
vector<Edge> ve;
/// link black b2
int nt=1;
for(;nt<b2+2;nt++)
ve.push_back((Edge){nt,nt+1,1});
b1-=2;
/// link black b1
for(nt++;b1;b1-=2,nt+=2)
ve.push_back((Edge){nt,nt+1,1});

/// link white w2
nt=1;
for(;nt<w2+2;nt++)
ve.push_back((Edge){white[nt],white[nt+1],0});
w1-=2;
/// link white w1
for(nt++;w1;w1-=2,nt+=2)
ve.push_back((Edge){white[nt],white[nt+1],0});

int sz=ve.size();
printf("%d\n",sz);
for(int i=0;i<sz;i++)
printf("%d %d %d\n",ve[i].u,ve[i].v,ve[i].c);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: