您的位置:首页 > 其它

HDOJ_Problem Archive_1004_Let the Balloon Rise

2015-07-26 14:23 363 查看
题目链接:点击打开链接

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink


我的C++程序:

#include<iostream>
#include<map>
#include<string>
using namespace std;
int main()
{
int i = 0, n = 0, max = 0;//n气球个数,max某个颜色最大出现次数
string s;
while (cin>>n)
{
if (n == 0)//输入0,结束程序
return 0;
max = 0;
map<string, int>input;//记录输入的气球颜色次数
for (i = 0; i < n; i++)
{
cin >> s;
input[s]++;//次数+1
}
for (auto i : input)//遍历map查找最受欢迎的颜色
{
if (i.second >= max)
{
s = i.first;
max = i.second;
}
}
cout << s<<endl;
}
//system("pause");
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: