您的位置:首页 > 产品设计 > UI/UE

poj 2031 Building a Space Station

2015-07-26 11:12 417 查看
http://poj.org/problem?id=2031

Building a Space Station
Time Limit:1000MS Memory Limit:30000KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.

The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n

x1 y1 z1 r1

x2 y2 z2 r2

...

xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0


Sample Output

20.000
0.000
73.834


英文题目太长,翻译不通,就看了别人博客翻译

题目大意:

就是给出三维坐标系上的一些球的球心坐标和其半径,搭建通路,使得他们能够相互连通。如果两个球有重叠的部分则算为已连通,无需再搭桥。求搭建通路的最小费用(费用就是边权,就是两个球面之间的距离)。



解题思路:

不要被三维吓到了,其实就是图论的最小生成树问题

球心坐标和半径是用来求 两点之间的边权 的,求出边权后,把球看做点,用邻接矩阵存储这个无向图,再求最小生成树,非常简单的水题。



把球A和球B看做无向图图的两个结点,那么

边权 = AB球面距离 = A球心到B球心的距离 – A球半径 – B球半径



边权直接用上面的公式求,接下来再用Prim就能完美AC了

注意若边权<=0,说明两球接触,即已连通,此时边权为0



很简单的一道最小生成树,不过定义坐标,距离等变量的时候一定要定义成double类型,由于我写代码的时候将minx定义成了int类型,WA了好多次,心塞呐





#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 1100
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8

struct node
{
    double x, y, z, r;//应该初始化为double类型
}stu
;

int n, m, vis
;
double ans, g

, dist
;

void prim (int sa);
void Init ();

int main ()
{
    while (scanf ("%d", &n), n)
    {
        ans = 0.0;
        Init ();
        for (int i=1; i<=n; i++)
            scanf ("%lf%lf%lf%lf", &stu[i].x, &stu[i].y, &stu[i].z, &stu[i].r);

        for (int i=1; i<n; i++)
        {
            for (int j=i+1;j<=n; j++)
            {
                double d = sqrt ((stu[i].x - stu[j].x) * (stu[i].x - stu[j].x) + (stu[i].y - stu[j].y) * (stu[i].y - stu[j].y)
                + (stu[i].z - stu[j].z) * (stu[i].z - stu[j].z)) - stu[i].r - stu[j].r;

                if (d <= EPS) g[i][j] = g[j][i] = 0;
                else g[i][j] = g[j][i] = min (g[i][j], d);
            }
        }
        prim (1);
    }
    return 0;
}

void prim (int sa)
{
    for (int i=1; i<=n; i++)
        dist[i] = g[sa][i];
    dist[sa] = 0;
    vis[sa] = 1;

    for (int i=1; i<n; i++)
    {
        int index;
        double minx = INF;//double类型
        for (int j=1; j<=n; j++)
            if (!vis[j] && minx > dist[j])
                minx = dist[index = j];

        vis[index] = 1;
        ans += dist[index];

        for (int j=1; j<=n; j++)
            if (!vis[j] && dist[j] > g[index][j])
                dist[j] = g[index][j];
    }
    printf ("%.3f\n", ans);
}

void Init ()
{
    memset (vis, 0, sizeof (vis));

    for (int i=1; i<=n; i++)
        for (int j=1; j<=n; j++)
            g[i][j] = INF;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: