您的位置:首页 > 其它

[水题] HDU 1049 Climbing Worm

2015-07-24 13:15 393 查看
C - Climbing Worm

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input

10 2 1

20 3 1

0 0 0

Sample Output

17

19

一个蜗牛在井底,井的高度为n,每分钟往上爬u米,爬完以后要休息一分钟,这一分钟休息时往下滑d米,问最少需要多少时间到达井口。

水题,纯暴力直接模拟整个过程。

#include <cstdio>
#include<iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
int n,u,d;
while(scanf("%d%d%d",&n,&u,&d))
{
if (n==0 && u==0 && d==0) break;
int time = 0, pos = 0;
while(1)
{
pos += u;
time++;
if (pos>=n) break;
pos -= d;
time++;
}
printf("%d\n",time);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: