您的位置:首页 > 其它

hdoj 1002 A + B Problem II

2015-07-24 11:47 204 查看
题目描述:

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 260678 Accepted Submission(s): 50403



[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


思路:这是一道大数求和问题,用字符数组做就行了。

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define M 2000
int a1[M+10];
int a2[M+10];
char s1[M+10];
char s2[M+10];
int main()
{
int n,k=1,i,j,l1,l2,max,f;

scanf("%d",&n);
while(n--)
{
f=0;
scanf("%s",s1);
scanf("%s",s2);
l1=strlen(s1);
l2=strlen(s2);
max=(l1>l2)?l1:l2;
//printf("max=%d\n",max);
memset(a1,0,sizeof(a1));
memset(a2,0,sizeof(a2));
for(i=l1-1,j=0;i>=0;i--)
{
a1[j++]=s1[i]-'0';
}
for(i=l2-1,j=0;i>=0;i--)
{
a2[j++]=s2[i]-'0';
}
for(i=0;i<max;i++)
{
a1[i]+=a2[i];
if(a1[i]>=10)
{
a1[i]=a1[i]-10;
a1[i+1]++;
}
}
if(k!=1)
{
printf("\n");
}
printf("Case %d:\n",k);
printf("%s + %s = ",s1,s2);
for(i=max+10;i>=0;i--)
{
if(a1[i]==0&&f==0)
continue;
else if(a1[i]!=0||f!=0)
{
printf("%d",a1[i]);
f++;
}
}
printf("\n");
k++;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: