您的位置:首页 > 其它

hdoj 1002 A + B Problem II【大数加法】

2015-07-24 10:41 204 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 260585 Accepted Submission(s): 50389


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
#define MAX 1100
char str1[MAX],str2[MAX];
int a[MAX],b[MAX];
int main()
{
int n,m,j,i,s,t,l1,l2,k,ok;
scanf("%d",&t);
k=1;
while(t--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%s%s",str1,str2);
l1=strlen(str1);
l2=strlen(str2);
for(i=l1-1,j=0;i>=0;i--)
{
a[j]=str1[i]-'0';
j++;
}
for(i=l2-1,j=0;i>=0;i--)
{
b[j]=str2[i]-'0';
j++;
}
n=0;
if(l1<l2)
{
n=l1;
l1=l2;
l2=n;
}
for(i=0;i<l1;i++)
{
a[i]=a[i]+b[i];
if(a[i]>=10)
{
a[i]-=10;
a[i+1]++;
}
}
ok=0;
if(a[l1]>0)
{
ok=1;
}
printf("Case %d:\n",k++);
printf("%s + %s = ",str1,str2);
if(!ok)
for(i=l1-1;i>=0;i--)
printf("%d",a[i]);
else
for(i=l1;i>=0;i--)
printf("%d",a[i]);
printf("\n");
if(t)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: