您的位置:首页 > 其它

What Is Your Grade?

2015-07-23 21:14 267 查看

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9469    Accepted Submission(s): 2903


[align=left]Problem Description[/align]
“Point, point, life of student!”

This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.

There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only
when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.

Note, only 1 student will get the score 95 when 3 students have solved 4 problems.

I wish you all can pass the exam!

Come on!

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed
time). You can assume that all data are different when 0<p.

A test case starting with a negative integer terminates the input and this test case should not to be processed.

 

[align=left]Output[/align]
Output the scores of N students in N lines for each case, and there is a blank line after each case.

 

[align=left]Sample Input[/align]

4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

 

[align=left]Sample Output[/align]

100
90
90
95

100C语言程序代码/*
题意::
    给出5道题,若完成5道则给100分,若做4道题要分两种情况(1、按时间排名,在前半段
 的给95分,后半部分给90分) 则以后以此类推有85,80,75,70,65,60分,当做0道题时
 给50分。
解题思路::
      这题本身是个简单的结构体,但难的是要达到分阶段给分这个目的是不容易的
    此代码所用方式为定义四个变量用来分别记录做4,3,2,1道题的人数,然后
    将作出相同的题数的人的时间从小到大排序,前半部分分别给95 ,85,75,65分
    当然,还有一个重点是,要记录学生的位置,然后按相应位置给出对应分数。
   
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct student
{
 int qm;/*解决问题的数目*/ 
 int lo;/*学生的位置*/ 
 char sj[100];/*所花费的时间*/ 
 int fs;/*最终的成绩*/ 
}stu[101];
bool c1(student x,student y)
{
 return strcmp(x.sj,y.sj)<0;
}
int main(){
 student s[4][101];
 student s1[101];
 int t,n,m,i,j,a,b,c,d;
 while(scanf("%d",&t)!=EOF)
 {
  
  if(t==-1)
      break;
   a=b=c=d=0;
  for(i=0;i<t;i++)
  {
   scanf("%d %s",&stu[i].qm,stu[i].sj); 
   stu[i].lo=i;  
    if(stu[i].qm==5)
    {
     stu[i].fs=100;
    }
    if(stu[i].qm==4)
    {
     s[0][a]=stu[i];
     a++;
    }
    if(stu[i].qm==3)
    {
     s[1][b]=stu[i];
     b++;
    }
    if(stu[i].qm==2)
    {
     s[2][c]=stu[i];
     c++;
    }
    if(stu[i].qm==1)
    {
     s[3][d]=stu[i];
     d++;
    }
    if(stu[i].qm==0)
    {
     stu[i].fs=50;
    }
  }
  if(a>=1)
  {
   sort(s[0],s[0]+a,c1);
   for(i=0;i<a/2;i++)
   {
    stu[s[0][i].lo].fs=95;
   }
   for(;i<a;i++)
   {
    stu[s[0][i].lo].fs=90;
   }
  }
  if(b>=1)
  {
   sort(s[1],s[1]+b,c1);
   for(i=0;i<b/2;i++)
   {
    stu[s[1][i].lo].fs=85;
   }
   for(;i<b;i++)
   {
    stu[s[1][i].lo].fs=80;
   }
  }
  if(c>=1)
  {
   sort(s[2],s[2]+c,c1);
   for(i=0;i<c/2;i++)
   {
    stu[s[2][i].lo].fs=75;
   }
   for(;i<c;i++)
   {
    stu[s[2][i].lo].fs=70;
   }
  }
  if(d>=1)
  {
   sort(s[3],s[3]+d,c1);
   for(i=0;i<d/2;i++)
   {
    stu[s[3][i].lo].fs=65;
   }
   for(;i<d;i++)
   {
    stu[s[3][i].lo].fs=60;
   }
  }
  for(i=0;i<t;i++)
  {
   printf("%d\n",stu[i].fs);
  }
  printf("\n");
 }
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: