您的位置:首页 > 其它

hdoj-1001 sum problem

2015-07-23 17:33 337 查看
该题虽简单 但多次运行不是wa就是ce 全都是因为没读懂题意 英语渣渣

把输入的第一个数据误以为要处理的数据的组数

误以为处理完一组数据 后面跟空行



Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 341149 Accepted Submission(s): 85985



Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.





Input
The input will consist of a series of integers n, one integer per line.


Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.


Sample Input

1
100



Sample Output

1

5050




[code]#include<stdio.h>
int main()
{
 int m,n,sum;
 while(scanf("%d",&n)!=EOF)   //多组输入 
 {
  sum=0;
     for(m=1;m<=n;m++)       
  {
   sum+=m;
  }
/*或者  for(;n>0;n--)  较简便 
  {
   sum+=n;
  } */
   printf("%d\n",sum);
   printf("\n");        //注意:每一个输出结果后跟一个空行 
  }
 return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: