您的位置:首页 > 其它

HDU1711

2015-07-22 18:52 316 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14563 Accepted Submission(s): 6392


[align=left]Problem Description[/align]
Given
two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2],
...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your
task is to find a number K which make a[K] = b[1], a[K + 1] = b[2],
...... , a[K + M - 1] = b[M]. If there are more than one K exist, output
the smallest one.

[align=left]Input[/align]
The
first line of input is a number T which indicate the number of cases.
Each case contains three lines. The first line is two numbers N and M (1
<= M <= 10000, 1 <= N <= 1000000). The second line contains
N integers which indicate a[1], a[2], ...... , a
. The third line
contains M integers which indicate b[1], b[2], ...... , b[M]. All
integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

[align=left]Sample Output[/align]

6
-1

[align=left]Source[/align]
HDU 2007-Spring Programming Contest

[align=left]Recommend[/align]
lcy

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int s[1000005],t[10005];
int Next[1000005];
int ans;
void getNext(int b){
int i=0,j=-1;
Next[0]=-1;
while(i<b){
if(j==-1||t[i]==t[j]){
i++;
j++;
Next[i]=j;
}
else
j=Next[j];
}
}
int kmp(int a,int b){
int i=0,j=0,sum=0;
while(i<a){
if(j==-1||s[i]==t[j]){
i++;
j++;
}
else
j=Next[j];
if(j==b){
ans=i+1-b;///该步需要特别注意一下即可
return ans;
}
}
return -1;
}
int main(){
int tt;
scanf("%d",&tt);
while(tt--){
memset(s,0,sizeof(s));
memset(t,0,sizeof(t));
memset(Next,0,sizeof(Next));
int t1,t2;
scanf("%d%d",&t1,&t2);
int temp;
for(int i=0;i<t1;i++){
scanf("%d",&s[i]);
}
for(int i=0;i<t2;i++){
scanf("%d",&t[i]);
}
getNext(t2);
int pd;
pd=kmp(t1,t2);
printf("%d\n",pd);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: